Intermittent .IO resolution issues
Incident Report for DNSimple
Resolved
While 2 IO name servers are still not responding to queries, we have not received further notices of issues from customers regarding this incident. It appears the original source of the incident was certain name servers in the IO group responding with NXDOMAIN responses when they should not have. As such, we are marking this as resolved.
Posted Oct 28, 2016 - 14:57 UTC
Update
We can confirm that at least 2 .IO name servers are currently misbehaving.

```
$ for i in {ns-a1.io,ns-a2.io,ns-a3.io,ns-a4.io,ns-d1.io,ns-l1.io,ns-y1.io}; do; echo "$i"; dig @$i dnsimple.io +short; done

ns-a1.io
ns-a2.io

; <<>> DiG 9.8.3-P1 <<>> @ns-a2.io dnsimple.io +short
; (2 servers found)
;; global options: +cmd
;; connection timed out; no servers could be reached
ns-a3.io
ns-a4.io

; <<>> DiG 9.8.3-P1 <<>> @ns-a4.io dnsimple.io +short
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached
ns-d1.io
ns-l1.io
ns-y1.io
```

We reported the issue to the .IO registry.
Posted Oct 28, 2016 - 09:05 UTC
Identified
We have identified the root cause. It looks some of the .IO top level domain name servers are not responding properly. We are contacting the .IO registry to report them the issue.
Posted Oct 28, 2016 - 08:49 UTC
Investigating
We are investigating reports of intermittent resolution failures for .IO domains.
Posted Oct 28, 2016 - 08:47 UTC