Zone updates delayed
Incident Report for DNSimple
Resolved
Zone updates have now returned to normal.
Posted Dec 01, 2016 - 13:17 UTC
Investigating
We are currently investigating delays in queue processing. DNS resolution should not be impacted.
Posted Dec 01, 2016 - 13:13 UTC