DNS update propagation delays
Incident Report for DNSimple
Resolved
Zone changes should now be propagating in a timely fashion to our AMS data center. Thank you for your patience.
Posted Jun 30, 2016 - 10:27 UTC
Identified
We have identified issues with DNS propagation in our AMS data center and are working to resolve this issue at the moment. DNS resolution of existing zone data is not affected.
Posted Jun 30, 2016 - 10:14 UTC